eAccelerator binaries for PHP 4.x (windows builds)

Update: eAccelerator compiled using latest code (0.9.5 RC1). I also recompiled a new version of 0.9.4 code (trying to resolve: getting multiple Apache 2.2.2 crash, per day, using eAccelerator with PHP 4.4.3).

Please find following the compiled binaries of eAccelerator for Windows using Microsoft VC++ 6. These binaries are built for  PHP 4.X versions.
PHP 5 versions:
eAccelerator binaries for PHP 5.x.

eAccelerator windows binaries follow the naming conversion: eAcceleratorVVV_PHPVERSION.dll with:
VVV: the version of eAccelerator
PHPVERSION: the version of the targeted PHP

Example eAccelerator094_4.3.11.dll is built from eAccelerator version 0.9.4 targeting the php version 4.3.11.
You can rename your download following the "standard" names:
eAccelerator.dll
eLoader.dll

Help with installing and configuring eAccelerator.

I can't possibly offer the combination of all PHP versions with all eAccelerator versions. If you need one not offered here let me know (post comment).

Technical Notes:
If you see a SiteBuddy version it means the original code had to be modified with "known" published solutions to get it to compile. The "SiteBuddy" version will be my custom brew.
For eAccelerator 0.9.5 to compile on PHP 4 needed to comment out 2 lines of code referencing the function "zend_do_inheritance" in the file ea_restore.c. NOT SURE OF THE CONSEQUENCES ? Could range from little impact on poeple using the encoder (most users do not?) to more grave....If someone know please post comment.... If you test it please let us know your results. Thanks!

File details, when applicable:
VERSION_Useful_File.zip contains the readme and the divers php files (control panel etc...).

Following you can download the eAccelerator binaries for your version of PHP 4.X.
Please post any positive or negative experience you have using these downloads. Avoid posting bugs related to eAccelerator (binary bugs will most likely appear immediately: when loading or first use). Please do not post support issues about eAccelerator under this article. You can do so in the eAccelerator Section of the Forums.

AttachmentSize
eAccelerator.dll 0.9.4 for PHP 4.3.11116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.3.11116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.4.1136 KB
eAccelerator.dll 0.9.4 for PHP 4.4.2116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.4.2116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.4.2 with disassembler116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.4.3136 KB
eaccelerator_0.9.4_Useful_files.zip11.07 KB
eLoader.dll 0.9.5RC1_Sitebuddy for PHP 4.4.324 KB
eAccelerator.dll 0.9.5RC1_SiteBuddy for PHP 4.4.3108 KB
eAccelerator.dll 0.9.4_SiteBuddy_V2 for PHP 4.4.3116 KB
eAccelerator.dll 0.9.4_SiteBuddy for PHP 4.4.4136 KB
eAccelerator094 Sitebuddy_v2 for PHP 4.4.4116 KB
eAccelerator094 Sitebuddy_v2 for PHP 4.3.11116 KB
eAccelerator094 Sitebuddy_v2 for PHP 4.3.2 (Request)116 KB
eAccelerator095 Sitebuddy See Note Above for PHP 4.4.4108 KB
eLoader.dll 0.9.5 Sitebuddy See Note Above for PHP 4.4.424 KB
095 final useful files41.97 KB
eAccelerator095 Sitebuddy See Note Above for PHP 4.4.1108 KB
eLoader.dll 0.9.5 Sitebuddy See Note Above for PHP 4.4.124 KB
eLoader.dll 0.9.5 Sitebuddy See Note Above for PHP 4.4.524 KB
eAccelerator 0.9.5 Sitebuddy See Note Above for PHP 4.4.5108 KB
eLoader.dll 0.9.5 Sitebuddy for PHP 4.4.624 KB
eAccelerator 0.9.5 Sitebuddy for PHP 4.4.6108 KB
eLoader.dll 0.9.5 Sitebuddy for PHP 4.4.724 KB
eAccelerator 0.9.5 Sitebuddy for PHP 4.4.7108 KB
eLoader.dll 0.9.5.1 Sitebuddy for PHP 4.4.724 KB
eAccelerator 0.9.5.1 Sitebuddy for PHP 4.4.7108 KB
eAccelerator 0.9.5.1 Sitebuddy for PHP 4.4.8108 KB
eAccelerator 0.9.5.1 Sitebuddy for PHP 4.4.9108 KB


0.9.4 on 4.4.9

It's perhaps a long-shot, but any chance you could compile 0.9.4 for PHP 4.4.9? We need the encryption functionality which was removed in 0.9.5. If not, is there any chance you could send me your tweaked 0.9.4 code for us to compile ourselves? From what you say above it is not simply a matter of compiling the standard eAccelerator code (or am I misunderstanding your technical notes?). Cheers - Mark

eAccelerator 0.9.4 on php 4.3.11

The best might be to move to php 4.3.11 and grab our 094 eA version.

php-4.4.9

Do you have a version for the latest php-4.4.9?

Thanks!

New eAccelerator for php 4.4.9

Hi Guys,

Just release the new version of eA.
Let usually please provide feedback (only if you already know eA pretty well).

Thanks & Happy Holidays,
Chris

Help! which one is for PHP 4.3.3 ?

Help! which one is for PHP 4.3.3 ?

Sorry, unless a compelling

Sorry, unless a compelling reason for an older version of PHP 4. We are not planning at this time to make any new releases on PHP4. You should be able to perform a minor upgrade to your version PHP to match one of the version we have available.

Cheers,
C

Need one for 4.4.8

Do you have a version for the latest php 4 release? 4.4.8

Thanks!

eAccelerator 0951 for PHP 4.4.8...

eAccelerator 0951 for PHP 4.4.8 released.

Please provide feedback, if you are already an experienced eAccelerator user.

Thx,
Chris

well try to get this version

well try to get this version done, next week.

Need version

Hey buddy

Is it possible for you to compile a new version for 4.3.10 PHP version ?

Tks in advance for any help !

Bye.

older eA version release for php 4.3.10

Hi Andres,

Here it is: Older versions of eAccelerator

For v4.2.3

Hi Buddy,

Could you please give me eAccelerator for php ver 4.2.3? I'm in need of this help.

Regards,
Hari Prakash.

Hi Hari, I will see if I can

Hi Hari,

I will see if I can get to that (maybe when I do binaries for the next main version). The holiday season is really busy here.

Why not upgrade to 4.3.11?

Cheers,
Chris

Tried this after updating to

Tried this after updating to php 4.4.7 on Windows

Checked the php version at the command line (using cli\php.exe -v
Reported 4.4.7

Tired both 4.4.7 sitebuddy dlls and it said that the 4.4.7 sitebuddy cannot be used as I am using php 4.4.6 which is not true?

Try the tool called

Try the tool called FileMonitor here: FileMonitor

Turn it on and then load one of you php page and see which dlls or .exes get loaded. You
probably have an old php 4.4.6 in your path (system folder?)....

eAccelerator for PHP 4.4.7

eAccelerator for PHP 4.4.7 works perfectly.
Thanks for the fast update,

Willem

It works!

Hi Chris!

It seems to work like a charm:
eAccelerator 0.9.5 [shm:win32 sem:win32]
PHP 4.4.7 [ZE 1.3.0]
Using cgi-fcgi on Windows NT

Thank you again!
Philippe.

Thank you!

THANK YOU VERY MUCH!! I will immediately try the new eaccelerator on my web server.

Hi Chris!How are you? Is

Hi Chris!

How are you? Is your child growing up? :)

New 4.4.7 PHP version has been just released. Could you kindly re-compile eaccelerator for this new one version?

Thanks in advance, as usual.
Best regards.

eA for PHP 4.4.7 released

Hi Phil,

She is growing great (already doubled in size!).
Please post a message to let me know if it works or not.

Thanks,
Chris

eAccelerator 0.9.5 for PHP 4.4.6 doesn't work for IIS6 & 2K3

Tried to use this. It really sped things up but crashes all the time. Tried older version with older PHP installs and same thing and can't seem to find any support.

Is this a dead project?

Thank you!

Thank you very much Mr.Chris for your work and your kindness!

PHP 4.4.6 Released

Oops... looks like version 4.4.6 has been released. Need your help to compile a new version for this.

And congratulations for your baby, Chris!

EA 0.9.5 for PHP 4.4.6 released

Thanks lam....eAccelerator 095 for PHP 4.4.6 released.

PHP 4.4.5 released...

Hi "magic-Chris"!

I noticed that PHP 4.4.5 has been just released:
http://www.php.net/downloads.php

Do you plan to release eaccelerator for PHP 4.4.5/Windows?

Many thanks in advance.
Best regards.
Philippe.

Hi Phillipe, I will try to

Hi Phillipe,

I will try to in the next few days. Pretty busy right now and expecting a baby real soon...

Thank you!

Many congratulations, Chris!

I need the eaccelerator for 4.4.5 for production purposes. Your help will be very much appreciated!

Thanks again. :)

ea 0.9.5 for PHP 4.4.5 released

Well it should be released within the next 5 minutes. Setting up php 4.4.5 as I type....

Update: Release done...

It works!

Hi Chris!

You are the best! eAccelerator+PHP 4.4.5+fastcgi seems to work well in my Windows 2000 SP4 machine.
My problem was that I was using the old eaccelerator.php file instead of the new control.php.

Thanks again to you and many many congratulations for your child!

Thanks Philippe !

Thanks Philippe !

Yes don't forget to get the new control panel file under the link "095 final useful files".

Cheers,
Chris